Debian 10 Üzerine Cisco Packet Tracer 7.2.2 Kurulumu

Bu video size Debian 10 Buster işletim sistemi üzerinde Packet Tracer 7.2.2 sürümünü nasıl kuracağınızı gösterir.

Debian’da Packet Tracer Nasıl Kurulur?

Debian tutarlı ve istikrarlı bir GNU/Linux işletim sistemidir. Geliştirme projesine başlanmasıyla birlikle 2 yıl sonrası Buster 10 kod adlı sürümü yayınlandı. Ayrıca, Security ve Long Term Support tarafından bu sistem 5 yıl desteklenecektir.

BlackFriday

Eğer Debian sistemizde Cisco sınavlarına çalışmak istiyorsanız, Packet Tracer’ı kurarak işe başlayabilirsiniz.

Debian’ın eski sürümlerinde ağ simülatör programını kurarken bazı hatalar ile karşılaşılmaktaydı. Yeni sürümü için bu durum geçerlidir fakat bazı ek bağımlı paketleri kurarak bu sorunu giderebilirsiniz.

Şimdi, Packet Tracer’ı çalıştırabilmek için:

Adım 1: Daha önce bir sanal makinede Debian’ı işletim sistemini kurmadıysanız, aşağıdaki videoya göz atınız.

Video: https://www.youtube.com/watch?v=dicvg6BbSs8

Adım 2: Debian’ı kurup çalıştırdıktan sonra, öncelikle bilgisayarınızda bir ağ dizaynı yapmak ve projeler geliştirmek için simülatör programını indiriniz.

Adım 3: Programı indirdikten sonra, setup dosyasını masaüstüne kopyalayınız.

Adım 4: Terminal’i açınız ve indirdiğiniz dosyanın izin haklarını değiştirmek için chmod +x PacketTracer-7.2.2-ubuntu-setup.run komutunu kullanınız.

chmod +x PacketTracer-7.2.2-ubuntu-setup.run

Adım 5: Packet Tracer’ı GUI wizardını çalıştırarak kuruluma başlamak için terminalde ./PacketTracer-7.2.2-ubuntu-setup.run komutunu çalıştırınız.

./PacketTracer-7.2.2-ubuntu-setup.run

Adım 6: Cisco Setup GUI açıldığında lisans anlaşmasını kabul ediniz, kurulum klasörünü /opt/pt/ olarak bırakınız ve kurulumu tamamlayınız.

Adım 7: Yazılımı bilgisayarınıza yükledikten sonra, programı çalıştırmak için terminal’de packettracer komutunu çalıştırınız.

packettracer

Adım 8: Eğer Packet Tracer başlamıyor ve herhangi bir hata vermiyorsa, bağımlı paketlerini bilgisayarınıza kurmanız gerekiyor. Libpng paketini indirip kurmak için terminalde aşağıdaki komutları çalıştırınız.

wget http://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb
dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

Adım 9: Libpng’yi kurarken multiarch paketini de kurmanızı isteyen bir uyarı görürseniz, aşağıdaki komutu çalıştırınız.

sudo apt-get install multiarch-support

Adım 10: Multiarch paketini yükledikten sonra, libpng’yi tekrar kurmaya çalıştığınızda bu kez aşağıdaki gibi bir hata alabilirsiniz. Bu hatayı çözmek için ise, libpng arşiv dosyasını klasöre ayıklamanız ve libpng12.so.0 dosyasını gerekli konuma kopyalamanız gerekir.

(Reading database ... 157517 files and directories currently installed.)
Preparing to unpack libpng12-0_1.2.50-2+deb8u3_amd64.deb ...
Unpacking libpng12-0:amd64 (1.2.50-2+deb8u3) ...
dpkg: error processing archive libpng12-0_1.2.50-2+deb8u3_amd64.deb (--install):
unable to install new version of '/usr/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory
Errors were encountered while processing:
libpng12-0_1.2.50-2+deb8u3_amd64.deb

Adım 11: Terminal’de aşağıdaki komutları çalıştırınız ve libpng12.so.0 dosyasını /opt/pt/bin/ klasörüne kopyalayınız.

mkdir cpt; dpkg -x libpng12-0_1.2.50-2+deb8u3_amd64.deb ./cpt
cp ./cpt/lib/x86_64-linux-gnu/libpng12.so.0 /opt/pt/bin/

Adım 12: Şimdi, sisteminizde Cisco Packet Tracer’ı çalıştırmayı deneyiniz. Bu kez de aşağıdaki gibi bir hata alacaksınız.

Starting Packet Tracer 7.2.2
/usr/local/bin/packettracer: line 8: 2219 Aborted ./PacketTracer7 "[email protected]" > /dev/null 2>&1

Adım 13: Bu durumda Debian sisteminiz için libqt paketini kurmanız gerekiyor. Aşağıdaki komutu çalıştırarak libqt paketini kurunuz ve ardından Packet Tracer’ı çalıştırınız.

sudo apt-get install libqt5webkit5

Adım 14: Packet Tracer artık hatasız bir şekilde çalışacaktır!

   İlgili Yazılar

1. Mint Packet Tracer
2. Kali Packet Tracer
3. Kali Güncelleme
4. Debian Güncelleme
5. Ubuntu Sistem Özellikleri

 

tolgabagci

Tolga Bağcı

 
shares